Home Forums Newsletter Plugin Support Web version not working

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #64886
    wellmatic1
    Participant

    Hello,

    I also see that the web version of the newsletter does not work properly.
    We are getting a 404-Page not found error, when clicking on the View online link.
    It is showing the following

    /%7Bemail_url

    at the end of the url.

    The newsletter was made with the regular tool, not an extension.

    Thanks in advance for the help!

    #65009
    dk
    Participant

    Here’s a short story:

    A Newsletter is scheduled for today 2am. Although being really tired I want to make sure everything works out just as expected. Now, just a few seconds past two – after sending to a really large number of recipients has started, I notice, that the {email_url} shortcode does not work! Fortunatelly, my emailaddress was the first on the list. By the way, it neither worked in the test-mail, but I thought, this is just due to being a test…

    So I immediatelly hit STOP. Now, what would you do in my case at 2am?
    Proceed, sending a couple thousand emails with non working web url promoted prominently in the preheader section?

    Here’s what I just did:

    – Google returns nothing.

    – Checking this forum gives me two threads on the first page complaining, that {email_url} is apparently broken.

    Since I am not really keen to justify myself in just a few hours, I started searching for the search-and-replace functions. This is what I found:

    Starting at line 1062 in newsletter/includes/module.php

    if (!empty($email_id)) {
    $text = $this->replace_url($text, ‘EMAIL_URL’, $home_url . ‘?na=v&id=’ . $email_id . ‘&nk=’ . $nk);
    }

    For reasons unknown, $email_id is empty, so {email_url} does not get replaced.

    However, few lines above, you can see, that {unsubscription_url} makes use of the same URL-parameter (nek). This is being parsed correct with an id set. So to keep it short, I just replaced the above lines of code as follows:


    if (!empty($email)) {
    $text = $this->replace_url($text, ‘EMAIL_URL’, $home_url . ‘?na=v&id=’ . $email->id . ‘&nk=’ . $nk);
    }

    Voila!

    Perhaps you can imagine my joy after I fixed this code and gently pressed the ‘proceed’ button.
    (Of course after receiving a test and confirmed the working web URL, that is 🙂

    Time to go to bed 🙂 Good night!

    Edit: Version is 5.1.9

    • This reply was modified 4 years, 11 months ago by dk.
    #65540
    wellmatic1
    Participant

    thanks! worked for us, too!

    but it would be nice to have it fixed by the Newsletter team, since we were not be able to be update the plugin, having the module.php itself modified …

    #66223
    santacurz65
    Participant

    Hello wellmatic1,

    i confirm! The online view run with this changes!

    best regards

    Harald

    #66389
    Andrea Marini
    Participant

    Same for me on click i got this:
    http://www.domain.it/%7Bemail_url

    I think we should expect a fix with an update?

    Thanks.

    #71506
    Stefano
    Keymaster

    Hi, you’re running a version with a bug, it has been fixed on version 5.2.0+.

    Stefano.

    #72801
    Antzelika
    Participant

    Good morning.
    I am running 5.2.3 version but again {email_url} doesn’t work.
    More particularly, a message like ” It looks like nothing was found at this location. Maybe try a search? ” is appeared.
    Could you explain me if it’is my mistake or plugin’s?

    Thankyou!!!
    Angelika

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.