Home Forums Newsletter Plugin Support Unsubscribing is not working.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #310089
    Elena Anna Rieser
    Participant

    If I (or anybody else) click the unsubscribe bottom on my newsletter template I am not able to unsubscribe. I either land on the subscribe-page or I get the message that the subscriber is not found. What can I do to enable the unsubscribe-option?

    #310093
    Stefano
    Keymaster

    Hi, when it reports the subscriber is no longer there it means it has already unsubscribed. If you see the subscription form, probably your dedicated page for the Newsletter plugin (see the main settings) does not contain the [newsletter] shortcode but something else, maybe the [newsletter_form] shortcode.

    #310165
    Digilan AG
    Participant

    trying to reply here… not working

    [edit]removed example domain[/edit]

    #310166
    Digilan AG
    Participant

    Similar issue here. Dedicated page is set and only has [newsletter] short code in it.
    When the (still existing and “confirmed”) user clicks the unsubscribe-Link, only a screen with a blank text input for E-Mail address and an “update” button appears. Once the email address is being entered and the update button is pressed, the user becomes subscribed with no list assigned. He also gets the welcome message – which could be considered being funny.

    However, sometimes it works… After hours of testing cases and conditions I found unsubscribing works when logged in as a WP user (admin in my case) but does not work if not logged in.

    When logged in
    /?na=u&nk=30144-ced2b51128&nek=24-
    becomes
    /mailing/?nm=unsubscribe&nk=30144-ced2b51128&nek=24-

    When not logged in
    /?na=u&nk=30144-ced2b51128&nek=24-
    becomes
    /mailing/
    without any parameters and therefore causes the behaviour mentioned in the beginning.

    Directly entering /mailing/?nm=unsubscribe&nk=30144-ced2b51128&nek=24- when not logged in also forwards to just /mailing/

    #310200
    Stefano
    Keymaster

    Hi, please check if the page is containing exactly the [newsletter] shortcode and not the [newsletter_form] shortcode.

    Looking at your URL, the page should show the request to confirm the subscription. That message is the one configured on Subscribers/Unsubscribe panel: what’s in that configuration?

    Tnx.

    #310204
    Digilan AG
    Participant

    yes, it is exactly only the [newsletter] shortcode.
    the request message is only shown when I am logged in in WordPress.
    I’ve set up a custom one in /wp-admin/admin.php?page=newsletter_unsubscription_index

    Bitte bestätigen Sie, dass Sie sich abmelden möchten, indem Sie <a href="{unsubscription_confirm_url}">hier klicken</a>.

    #310218
    Stefano
    Keymaster

    Ok, I start suspecting you have a cache plugin that is serving the page ignoring the URL has some parameters. Can you check for it?

    #310228
    Digilan AG
    Participant

    This approach sounds reasonable but unfortunately is not the case. I have no cacheing plugin enabled. I use AiOSEO with a redirect addon which has the option to http cache redirect answers for a specified time but it is not enabled. 

    I tried using the unsubscribe link with a different browser.

    Again, it didn’t work and just redirected to the dedicated newsletter page without any parameters.
    Then I logged in into wordpress, pasted the same unsubscribe link … and voilá, the “please confirm…” message appeared.

    This behaviour makes me thinking it can’t be a caching issue.

    #310278
    Stefano
    Keymaster

    Could you share your site address so we can make some tests?

    #310287
    Digilan AG
    Participant

    sure, it’s outlog-architektur.ch

    #310356
    Digilan AG
    Participant

    opened a support ticket for further investigation

    #313553
    sdh
    Participant

    Did you ever get this working?
    Although i don’t have this exact problem, (unsubscribe works for we), I have a similar problem where user profiles don’t work.

    #313555
    sdh
    Participant

    Ok ignore me, i’ve fixed my one, i had to reinstall a couple of times and it fixed it.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.
×