Home Forums Newsletter Plugin Support Unsubscribe, Profile Page, Subscribe error etc. not working

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #245547

    I use your plugin and at first it’s great. I can subscribe and unsubscribe without problems.
    Along the way, now it’s broken.

    When people subscribe, the page redirect to https://xxxxx.xxx/newsletter?nm=confirmed&nk=xxxxx-xxxxxxxx but no Welcome message whatsoever.
    I try to subscribe using existing email, and then redirect to the same nm=confirmed and no Welcome message.. only Subscribe form that shows.

    Welcome emails are including link to profile url. But when I clicked it, it goes to https://xxxxx.xxx/?na=profile&nk=xxxxx-xxxxxxxx and it shows message: No subscriber found. on a very blank page (no header and footer from WordPress themes)

    On Newsletter emails, I include unsubscribe link. When I clicked it, it goes to https://xxxxxx.xxx/newsletter/?nm=unsubscription_error, and it only shows Subscribe form without any message.

    I am using SendGrid as email delivery service.
    I also use Newsletter Addon: Bounce, SendGrid, Reports, Google Analytics, Geo Resolvers. Have been trying to deactivate and activate again without any effects.
    Already try to deactivate other plugins (Monster Insights Google Analytics, HTTP Headers, iThemes Security, Disable Rest API) and nothing can resolve the problems.

    I suspect that the plugin fail to translate the Get variables from the newsletter url. And 1 problem that profile url goes to root url, and not newsletter url.

    Please advice, which way should I check…


    Hi, if the plugin does not see anymore the “get” variables, could be a server configuration or a plugin removing them. For example an optimizer or a cache. Could you check if you have one of those plugin and could you try to disable them?

    The newsletter dedicated page (/newsletter in you case) contains only the [ newsletter ] shortcode?



    I can confirm that I already try only use Newsletter plugin & remove non WordPress line in .htaccess.

    Yes I have dedicated page (/newsletter) which only contains [newsletter] shortcode.


    Ok, problem fixed.

    Accidentally, I have a real directory on server called “newsletter” also.

    So far the problem resolved.

    Thanks for your response.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.