Home Forums Newsletter Plugin Support Unsubscribe error

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #286036
    info
    Participant

    Hi,

    I am using the Newsletter plugin for a while now without any problems but suddenly the “unsubscribe” button in the newsletters is not working anymore. When I do a test myself I get this error message: “Already deleted or using the wrong subscriber key in the URL”. The subscriber is confirmed in the plugin and it is not already deleted. So my guess is that the subscriber key is wrong or not matching with the subscriber, but I have no clue how to fix this problem.

    Anybody an idea?

    Thanks!

    #286200
    Anonymous
    Inactive

    Hi,
    I am new to this plugin and I have exactly the same problem. I use the standard footer link, the subscriber is confirmed. I have no idea how to fix this critical problem because here in Germany this is a legal Must!
    Thank you for any help
    Josef

    #286201
    Stefano
    Keymaster

    Hi, if you have such an error, and the link is the personal link of that subscriber, it means it has already been canceled. If it has been resubscribed, the secret token changes and the old link does not work anymore.
    How do you test the link? If you send a test newsletter, that newsletter could have “fake” link since it is not linked to a real subscriber.

    #286203
    info
    Participant

    Hi, I have used the shortcodes {unsubscribe_url} and {profile_url} and I have also used the standard footer link but they all end up with the same error. I have tested it again with a new email that hasn’t been used in the Newsletter plugin and I still got the same error so I don’t think it has something to do with resubscribed or new subscribers. So any other suggestions? Maybe is there a way to get the subscribers secret token with a shortcode? That way maybe there is an possibility to create my own custom link where I know for sure that the token is the correct one.

    #286205
    Stefano
    Keymaster

    please, send me (stefano @ thenewsletterplugin.com) one of the not working url so I can see if there is something wrong with the format.
    Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
×