Home Forums Newsletter Plugin Support Translations not working

  • This topic has 4 replies, 2 voices, and was last updated 1 month ago by dos.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #312429
    dos
    Participant

    I’ve just installed the Newsletter Plugin on a site with WPML and two languages, EN + DE. I’ve set up two forms where I configured the labels in the shortcodes, which is working fine. But besides that, everything is always in english. I’ve set up the confirmation page in both languages, linked correctly in WMPL. After submitting the german form, it shows the german confirmation page (german title), but the plugin’s confirmation message and the Email-texts are in english.
    Also, when I change the Sender Name in main settings, it’s always overwriting both languages, so I can’t have two different names. Of course I have selected the language before, and the plugin shows which language it is currently configuring.
    Any ideas what’s wrong? Thanks a lot.

    #312542
    dos
    Participant

    I’ve also tested in a staging site with standard theme and deactivated all plugins except WPML and Newsletter. Still not working. Also it’s not sending double-opt-in mails, instead it immediately marks users as confirmed although they are not. This plugin seems to be completely broken currently. Any support here?

    #312544
    dos
    Participant

    double opt in is working when set specifically in each form, but not as global setting. is there an option to force the language of confirmation and email in the form-shortcodes?

    #312979
    Stefano
    Keymaster

    Hi, the form shortcode should include automatically the current language and it should be stored in the subscriber profile. That language is then used to show the messages.

    Could you kindly check if the subscribers registered, for example, by the german form have the german set as language?

    The opt-in is global: try to save the subscription setting for every language, even if the opt-in option is not shown: could be there is a stale configuration saved on the per language setting.

    #312998
    dos
    Participant

    Hi Stefano,
    that’s weird – saving the subscription settings page in every language (although there are no options at all) indeed fixed most of the problems. The message is now in the right language, the opt-in worked and the mail content also has the right language.
    Only one thing is missing – the sender name. In whatever language I save it, it always overwrites all languages. I also looked in the database, it looks like this information is stored only once?
    Thanks
    Dominik

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
×