Home Forums Newsletter Plugin Support Forum The WP scheduler doesn’t seem to be running correctly for Newsletter = 5 days?!

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #217524
    cecofuli
    Participant

    iao,

    sono italiano ma forse meglio scrivere in inglese..

    As some other people here, I have this message in my website.
    The hosting is Siteground.
    In my wp-config I havn’t any code like this:

    define(‘DISABLE_WP_CRON’, false);
    or
    define(‘DISABLE_WP_CRON’, true);

    and in my Siteground dashboard I have remove and Cron Jobs external setting.
    So, in the Newsletter Status I read:

    (*) Newsletter schedule timing:KO The scheduler is very late: -435645 seconds”
    435645??? It means 5 days….

    (*) Cron calls:KO The blog cron system is NOT triggered enough often.
    Trigger interval: average 1457 s, max 1801 s, min 20 s

    Here the screenshot

    View post on imgur.com

    And here, the screenshot of “Advanced Cron Manager” plug-in

    View post on imgur.com

    Can you help me to solve the problem?

    Thank you
    Francesco

    #217694
    Stefano
    Keymaster

    Hi, as shown by your cron manager the events are all “in queue” which is not a good condition. It means the internal scheduler of WP is not working. Have you setup a cron trigger (see our documentation for some ideas). Which is the blog address? I can try to call the cron trigger to check if any error is reported.

    Stefano.

    #217696
    Stefano
    Keymaster

    And what about the status panel? There is something reported?

    #217710
    cecofuli
    Participant

    Cavoli,

    ok, credo di aver capito il problema…

    Come indicato dalla sua guida, ho digitato

    http://www.xxxxx.com/wp-cron.php

    e.. guardi che cosa mi compariva nel browser!!!

    Fatal error: Uncaught Error: Class ‘OceanWP_EDD_Addon_Migration’ not found in /home/customer/www/xxx.com/public_html/wp-content/plugins/ocean-elementor-widgets/ocean-elementor-widgets.php:219 Stack trace: #0 /home/customer/www/xxx.com/public_html/wp-includes/class-wp-hook.php(286): ocean_elementor_widgets_fs_addon_init(”) #1 /home/customer/www/xxx.com/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /home/customer/www/xxx.com/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /home/customer/www/xxx.com/public_html/wp-content/themes/oceanwp/functions.php(981): do_action(‘owp_fs_loaded’) #4 /home/customer/www/xxx.com/public_html/wp-settings.php(499): include(‘/home/customer/…’) #5 /home/customer/www/xxx.com/public_html/wp-config.php(120): require_once(‘/home/customer/…’) #6 /home/customer/www/xxxx.com/public_html/wp-load.php(37): require_once(‘/home/cust in /home/customer/www/fxxx.com/public_html/wp-content/plugins/ocean-elementor-widgets/ocean-elementor-widgets.php on line 219

    Ovviamente la prima cosa che ho fatto è stata di disattivare i plugin del tema OceanWP (sono un loro utente premium).
    Disattivando OceanExtra, quell’errore non è più comparso. e pure il messaggio di errore di Newsletter plug-in

    Ho quindi verificato con Advanced-cron-manager e ora sembra tutto ok…
    Credo che scriverò immediatamente a quelli di OeanWP.
    Lei che idea si è fatto?
    .

    View post on imgur.com

    • This reply was modified 11 months, 2 weeks ago by cecofuli.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.