Home Forums Newsletter Plugin Support Spammers hammering me

Viewing 37 posts - 1 through 37 (of 37 total)
  • Author
    Posts
  • #79130
    BrianMack
    Participant

    The Russian spammers are hitting our Newsletter subscriber widget very hard over the last 2 days. Its getting worse. Every few minutes another .ru subscriber with spammy name and email addy.
    What can we do?
    Brian

    #79140
    Louis R
    Participant

    This has been happening to me as well over the last 2 days. Is there a way to block certain country extensions?

    Thanks for any assistance.

    Louis

    #79142
    Stefano
    Keymaster

    Ask the provider to block their IP address and rise the antflood time in the subscription settings.

    Stefano.

    #79155
    Stefan
    Participant

    Please let me know if you get fixed the spam subscription problems. This happens also to me and there is no way to stop it. I deactivated the plugin now. Would be great if the developer make a recaptcha integration option to the plugin.

    • This reply was modified 4 years, 8 months ago by Stefan.
    #79162
    BrianMack
    Participant

    The antiflood can only reach 5 minutes. Why not longer?
    Does premium offer anti spam protection?
    The .ru problem is growing exponentially 🙁

    #79182
    BrianMack
    Participant

    Anti flood is not helping!
    The .ru spam is getting worse.
    Looks like time for a new plugin sadly.

    #79184
    Louis R
    Participant

    I removed the subscribe widget completely and I put a password on the subscribe page to see if that stopped. It did not. The .ru subscribes are still coming through. There must be a back door that needs addressing I believe.

    Thanks.

    #79207
    BrianMack
    Participant

    We had to remove the Newsletter widget from our site.
    So sad it has come to this.

    #79216
    BrianMack
    Participant

    After removing all the Newsletter optins from our site the .ru spamming is still increasing at an alarming rate!!!
    Can anyone give some support here?

    #79225
    Stefan
    Participant

    still the same on our site. I deactivated the plugin. If I turn it on spam starts immediatly. Hope there is a solution soon.

    #79275
    ImmoBulgarije
    Participant

    This botnet that acts like it is Russian really is annoying.
    No option available to prevent them from directly accessing the registration url?
    Must be possible to prevent them subscribing.

    • This reply was modified 4 years, 8 months ago by ImmoBulgarije.
    #79339
    pertzschc
    Participant

    I have the same issue on my webside.

    “No option available to prevent them from directly accessing the registration url?”
    What is the registration url?

    Kind regards, Christoph

    #79341
    Louis R
    Participant

    I really like this plugin and have been using it for several years. It is rapidly becoming useless but I’m holding on hoping a fix is forthcoming. Not too much longer though.

    Louis

    #79345
    ImmoBulgarije
    Participant

    Or an option to temporarily prevent users with mail.ru addresses which gives more time to fix the issue

    #79349
    ImmoBulgarije
    Participant

    Maybe a temporarily fix to prevent users to register with a mail.ru address? Gives more time to fix it.

    #79356
    ImmoBulgarije
    Participant

    temporarily block mail.ru subscribers to have more time for a fix?
    All are mail.ru addresses

    #79381
    Louis R
    Participant

    This forum is only showing 12 posts and there seems to be no way to view all and follow the thread. No page 2, etc.

    #79572
    miwo
    Participant

    Same happened to me – before I came to this forum I thought it was a personal attack to my homepage. Now I’m a bit calmed 🙂 Looked in the ‘Newsletter Plugin’ MySQL Table, I mentioned, that the first attack was at 2018-03-13 23:03:45

    As I investigated in that issue, I found, that besides the inconvinience, there’s a severe risk of our IP/Domain being blacklisted at SPAMHAUS. The only solution seems to me to include a captcha in the subscription process: https://blog.goolara.com/2016/12/21/defusing-subscription-bombs/

    Because of the blacklist-risk, I have to change the automatic subscription form into a message to my potential readers: “Due to technical issues, we were forced to temporarily close automatic subscription to our newsletter service. Please send an email to me (xy@mydomain.de) and I will subscibe you to our newsletter personally.” But this is of course no longterm-solution. Is there any chance to get the Captcha-feature in the near future?

    Yours Michael

    #79779
    Stefano
    Keymaster

    Hi, the antibot feature already does few things to block the bots, but they execute even javascript. Blacklist their ip address is a viable solution.

    Stefano.

    #79781
    Stefano
    Keymaster

    Hi, the antibot feature already does few things to block the bots, but they execute even javascript. Blacklist their ip address is a viable solution.

    Stefano.

    #80525
    miwo
    Participant

    Blocking the IP adress wouldn’t be an option. I selected all entries from today – all from the spammers and all come from different IPs: http://www.it-freelancer-magazin.de/wp-content/uploads/2018-03-20-07_12_02-IT-Freelancer-Magazin_db12908265-ifm_wp_newsletter_-HeidiSQL-9.3.0.4984.png

    I think Captchas are the only and obvious solution to this. My hoster also give me that advice.

    #80536
    Stefan
    Participant

    The Team needs to integrate a Captcha (Silent Recaptcha would work also)!!
    THIS IS THE ONLY WAY!! Antiflod is no option or solution. The only way to stop it is to deactivat the plugin.
    I will not renew my subscription in case there is a Captcha integrated.
    So this makes me sad about this plugin. There is no quick solution if there is a big big problem like this!

    #80569
    pertzschc
    Participant

    Hi all,
    my (temporary) solution is, to block all “*mail.ru” adresses for subscription. If this fits for your needs, please adapt the following lines in the file: ..\wp-content\plugins\newsletter\subscription\subscription.php:

    search for this next comment statement in the file and insert the block “// begin patch for mail.ru”

    // Shound never reach this point without a valid email address
    if ($email == null) {
    die(‘Wrong email’);
    }
    // begin patch for mail.ru
    $email_contains_ru = strpos($email, “mail.ru”); // outputs greater 0 if found
    if ($email_contains_ru > “0”) {
    $this->logger->info(‘Subscription of “mail.ru” – address blocked: ‘ . $email);
    die();
    }
    // end patch for mail.ru

    $user = $newsletter->get_user($email);

    Kind regards,
    Christoph

    #80596
    ImmoBulgarije
    Participant

    First: For one reason or another I can only see the first 12 posts in this thread

    Second: the new update for the plugin has some errors, css I think

    Third: with version 5.2.6 I have not a single spammer subscribing… Maybe reversing to this version solves it?

    #80641
    DJDaniel
    Participant

    Same with me, no chance to get rid of these russian Spammers, so I deactivated the Plugin…very sad 🙁
    Hope there will be a solution soon, as I’d really like to use it again !

    #80650
    DJDaniel
    Participant

    I added this into the subscription.php

    // begin patch for mail.ru
    $email_contains_ru = strpos($email, “mail.ru”); // outputs greater 0 if found
    if ($email_contains_ru > “0”) {
    $this->logger->info(‘Subscription of “mail.ru” – address blocked: ‘ . $email);
    die();
    }
    // end patch for mail.ru

    It doesn’t work, trying to reactivate the Newsletter Plugin I got the followig Error:

    Parse error: syntax error, unexpected ‘of’ (T_STRING) in /homepages/…./wp-content/plugins/newsletter/subscription/subscription.php on line 399

    Line 399 Contains $this->logger->info(‘Subscription of “mail.ru” – address blocked: ‘ . $email);

    #80652
    pertzschc
    Participant

    DJDaniel wrote:

    I added this into the subscription.php

    It doesn’t work, trying to reactivate the Newsletter Plugin I got the followig Error:

    Parse error: syntax error, unexpected ‘of’ (T_STRING) in /homepages/…./wp-content/plugins/newsletter/subscription/subscription.php on line 399

    Line 399 Contains $this->logger->info(‘Subscription of “mail.ru” – address blocked: ‘ . $email);

    Please check for your PHP-version, what is the regular character for define a string, as there are many possibilities:
    “”, ”, , ‘‘.

    I think, that the <‘> is causing your issue, please try <‘> first.
    Christoph

    #80660
    DJDaniel
    Participant

    Thanks for helping, in fact I had to replace the <‘> by <‘>
    Now I’m curious if it works

    Daniel

    #80680
    DJDaniel
    Participant

    So I tried to register to the Newsletter with a fictive “mail.ru” adress and the adress was registered in the database of my Newsletter-Plugin so it seems, that the patch won’t work.

    Daniel

    #80702
    UAB “Delmoda”
    Participant

    Same for me. Why developers doesn’t comment anything? Looks quite strange. Should I delete this plugin?

    #80776
    rowa
    Participant

    the same on our side. I also deactivated the plugin. If I turn it on, spam starts immediately. Hopefully there will be a solution soon

    #80803
    pertzschc
    Participant

    Yesterday I did post a solution to patch subscription.php, now I will share an improved version:


    // Shound never reach this point without a valid email address
    if ($email == null) {
    die(‘Wrong email’);
    }

    // begin patch for blocking all mail adresses ending with “*.ru”
    $endStr = “.ru”;
    if (substr($email, strlen($email)-strlen($endStr), strlen($endStr)) === $endStr) {
    $this->logger->info(‘Subscription of “*.ru” – address blocked: ‘ . $email);
    die();
    }
    // end patch for blocking all mail adresses ending with “*.ru”

    $user = $newsletter->get_user($email);

    Please search the statements and copy in the // patch…
    It will block all subscriptions with mail adresses ending with “*.ru”.

    And no, it will not prevent to make a subscription with “mail.ru2” 😉

    Christoph

    #80896
    DJDaniel
    Participant

    There is a new Version (5.2.8) today

    #80905
    DJDaniel
    Participant

    The Update 5.2.8 doesn’t take an effect, Russian Spambots can subscribe anyway. Trying the Solution of Christoph now…

    #80918
    DJDaniel
    Participant

    UPDATE !
    Adding the Patch from Christoph doesn’t also take any effect, Spambots with .ru-Domains are not blocked. Seems that it’s the only solution to deactivate the Newsletter Plugin :-/
    Very sad that there is no Support from the Develloper-Team !

    Daniel

    #81115
    Riversong UG
    Participant

    Same problem here. It’s annoying. Thanks for your help. Best regards.

    #81991
    Arcus
    Participant

    With the latest update 5.3.1 it works great again …

Viewing 37 posts - 1 through 37 (of 37 total)
  • You must be logged in to reply to this topic.