Home Forums Newsletter Plugin Support Slow delivery despite cron

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #300262
    fabiantodt
    Participant

    Hi,

    I’ve got a newsletter list with ~600 subscribers. I’ve got a system cron job setup to trigger the WordPress cron system every 2 minutes and WP_DISABLE_CRON set to true. I’ve set the NEWSLETTER_CRON_INTERVAL to 120seconds.
    Still, sending a newsletter takes ~20 minutes for all emails to send. The cron job works correctly and there are no warnings about the scheduling system. I’m using my own SMTP which can handle all thes messages. It seems on each batch there are only 20-40 emails sent. Max emails per hour is set to 1000. I don’t see any sollected statistics about the delivery speed on the system/status page (the link from the max emails settings to “see the collected statistics” redirects to the page but no speed statistics are visible).
    Wouldn’t it be better to make a loopback request after sending one batch to trigger the sending instantly again? Something like action_scheduler does. This way it wouldn’t have to wait until the next cron schedule. I’m thinking about hooking into newsletter on a late priority and trigger a request myself.

    #300263
    Stefano
    Keymaster

    Hi, please check on the System panel the mean time to send a single email, could be the mail server is very slow. Could be the link to the stats are wrong, check the System/Status and in particular the “Send details” block of data.

    #300265
    fabiantodt
    Participant

    Hi, thanks for the fast response!
    I can’t find any “send details” block. Only “Delivery” where “Sending statistics” is “Not enough data available”. I’ve just send two newsletter until now.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
×