Home Forums Newsletter Plugin Support Running "Status" shows PHP execution time limit too low,but no suggested setting

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29193
    James LeDoux
    Participant

    Running the System Status indicates the PHP execution time limit is too low (showing a red “KO” indicator), but no suggested setting is given. I can’t find one in your docs either.

    A pretty high regular setting for PHP execution time limit is 300, but that wasn’t good enough for the Status. So I upped it to 600, ordinarily the highest recommended, from what I’ve read. And still I get the red indicator.

    I have a dedicated server (Nginx), and it’s got plenty of resources. So, how high is recommended for Newsletter, and what is too high, in your estimation?

    I’d appreciate any help, and I’d recommend going into more detail on the setting in your docs, with maybe a link to that in the plugin settings.

    Thank you!

    • This topic was modified 5 years, 10 months ago by James LeDoux.
    #29197
    James LeDoux
    Participant

    Also, the error message says, “Your PHP execution time limit is 600 seconds and cannot be changed or is too lower (sic)…”

    So, it sounds like Newsletter is trying to change the setting itself, is that right? Or is there a way to exempt this plugin from the limit?

    #29657
    Stefano
    Keymaster

    Newsletter tries to change temporary the value to know if it has the controls on it. WP it self change the timpout to 0 during import operation. If it is 600 o even 300 is ok. Usually it could be better to have it set at lower value and the let newsletter to increase it when needed (during a delivery batch).

    Stefano.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.