Home Forums Newsletter Plugin Support Problem after update the plugin

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #308441
    Anonymous
    Inactive

    Hello,

    after i have update the plugin i dont can activate.

    Das Plugin kann nicht aktiviert werden, da es einen fatalen Fehler erzeugt.

    Fatal error: Uncaught mysqli_sql_exception: Table ‘dbs23372.wp_newsletter_user_meta’ doesn’t exist in /homepages/38/d312784286/htdocs/wp2019/wp-includes/wp-db.php:2056 Stack trace: #0 /homepages/38/d312784286/htdocs/wp2019/wp-includes/wp-db.php(2056): mysqli_query() #1 /homepages/38/d312784286/htdocs/wp2019/wp-includes/wp-db.php(1945): wpdb->_do_query() #2 /homepages/38/d312784286/htdocs/wp2019/wp-includes/wp-db.php(2695): wpdb->query() #3 /homepages/38/d312784286/htdocs/wp2019/wp-admin/includes/upgrade.php(2749): wpdb->get_results() #4 /homepages/38/d312784286/htdocs/wp2019/wp-content/plugins/newsletter/includes/upgrade.php(32): dbDelta() #5 /homepages/38/d312784286/htdocs/wp2019/wp-content/plugins/newsletter/includes/upgrade.php(165): NewsletterUpgrade->db_delta() #6 /homepages/38/d312784286/htdocs/wp2019/wp-content/plugins/newsletter/includes/upgrade.php(514): NewsletterUpgrade->run() #7 /homepages/38/d312784286/htdocs/wp2019/wp-content/plugins/newsletter/plugin.php(227): include_once(‘/homepages/38/d…’) #8 /homepages/38/d312784286/htdocs/wp2019/wp-includes/class-wp-hook.php(303): Newsletter->hook_activate() #9 /homepages/38/d312784286/htdocs/wp2019/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters() #10 /homepages/38/d312784286/htdocs/wp2019/wp-includes/plugin.php(470): WP_Hook->do_action() #11 /homepages/38/d312784286/htdocs/wp2019/wp-admin/plugins.php(193): do_action() #12 {main} thrown in /homepages/38/d312784286/htdocs/wp2019/wp-includes/wp-db.php on line 2056

    have anybody an idee… i have delete and install new … same problem

    #308443
    Stefano
    Keymaster

    Hi, that error is generated by WP when it tries to update a table. It happens because you are using an old WP version with PHP 8.1. This version triggers exceptions on database errors that are not managed by your WP version.
    Consider to downgrade the PHP version to 7.x since those fatal errors can be generated by other plugins and WP itself on update.

    #308449
    Anonymous
    Inactive

    thank you, but an older version of php is evtl an security problem?

    #308624
    Anonymous
    Inactive

    ?? new version of the plugin to fix the problem

    #309837
    Anonymous
    Inactive

    Can anybody help please?

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
×