Home Forums Newsletter Plugin Support Exchange 2007

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #138339


    I’m struggling a bit to get The Newsletter Plugin to work using my Exchange 2007 server as sender – I want to do this to avoid the newsletters going in to SPAM. I’ve checked, and I am able to send using my SMTP server using an external service here:

    I’ve tried every combination of port (25 / 465 / 587), No secure protocol / SSL / TLS, Authentication, and Insecure SSL – but after a long pause I keep getting:

    2018-12-06 16:13:23	Connection: opening to smtp.mytld.co.uk:25, timeout=300, options=array (
                       	                    'ssl' => 
                       	                    array (
                       	                      'verify_peer' => false,
                       	                      'verify_peer_name' => false,
                       	                      'allow_self_signed' => true,
    2018-12-06 16:14:27	Connection: Failed to connect to server. Error number 2. "Error notice: stream_socket_client(): unable to connect to smtp.citi.co.uk:25 (Connection timed out)
    2018-12-06 16:14:27	SMTP ERROR: Failed to connect to server: Connection timed out (110)
    2018-12-06 16:14:27	SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    I’ve checked, and openssl is loaded and working on the external website host.

    I’ve also tried setting up an Exchange connector as an open relay for the external website host…

    Can anyone point me in the direction of the logs I need to check to see what is going wrong?

    Thanks in advance.



    Hi, the connection timeout is a sign of a connection block between the two server (the site server and the exchange server). Could be a firewall rule, you should check with the provider.



    Hi Stefano

    Thanks for your reply – I’ve worked on it some more today, and I have got it working now.

    It was an Exchange 2007 configuration issue 🙂



Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.