Home Forums Newsletter Plugin Support Change Translation File to Formal German

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #289339


    I changed the wordpress language from German to Formal German, but still the checkbox on the subscription Form uses informal German. Where and how can I force the newsletter Plugin to use the Formal Translation?

    Initially I tried to use Loco Translate to just change the specific String – but that has also been ignored by the newsletter Plugin.

    Please advice,


    I’m especially failing to get this string:

    “Indem Du fortfährst, akzeptierst Du unsere Datenschutzerklärung.”

    to display as:

    “Indem Sie fortfahren, akzeptieren Sie unsere Datenschutzerklärung.”

    The string has been successfully changed in the wp-content/languages/plugins/newsletter-de_DE.po – then compiled to newsletter-de_DE.mo, uploaded to the directory wp-content/languages/plugins – still the string is not being translated correctly. What am I missing?????


    Ok – hours later I found a solution to this issue – maybe I can help someone else who runs into this problem.

    As neither editing the translation files directly nor via loco translate was able to update the translated strings I figured that they are maybe written to the db during installation. So after some time I found out that this process does actually updated the translated strings for the newsletter plugin:

    1.) deinstall the plugin
    2.) make sure that there are no left over files in wp-content/language directory
    3.) in the db delete all newsletter tables
    4.) THE IMPORTANT PART: delete the newsletter_profile rows in the your-prefix option table
    5.) change the wordpress default language to whatever language you need (in my case it was the formal German Sie)
    6. reinstall the newsletter plugin

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.