Home Forums Newsletter Plugin Support Black Screen When Push Sending

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29940
    nigelh
    Participant

    Hi

    2 setups of the newsletter plugin on the same hosting provider, different domains, 2 users.

    Both on 4.8.0, same other plugins.

    Setup 1 – working fine
    Setup 2 – just shows black/blank screen when select to send either from the newsletter (sent-test option) or the status, send test email.

    Both use gmail smtp server plugin which sends the test email.

    Database structure identical for all 4 newsletter tables.

    Setup 1 – reporting 128MB which is correct
    Setup 2 – in status reporting 40MB which is incorrect as it has 128MB on wp-config as per setup 1

    I’ve tried disabling all other plugins except newsletter and gmail. Setting to not use smtp and just newsletter active – no change.

    Any ideas greatly appreciated.

    #29950
    Stefano
    Keymaster

    Hi, the black screen could hide a message writen in dark gray, can you check it? For example a database error.
    You can try to put Newsletter in debug mode (see the main settings) and then check on status panel for a php error log (last elements of that panel). Check there if there are some kind of errors reported.

    if the status panel report 40M it means WP is working with 40M. That could means you cannot change the memory limit can be a limitation of your provider.

    Stefano.

    #29984
    nigelh
    Participant

    Hi Stefano

    Thank you for your response. Max-memory is 128M in php.ini for the site, and wp-config.php, apache2 restarted, now showing the 128M.

    Newsletter set to debug=on, and Error reported as follows, sensitive part redacted.

    [20-Feb-2017 10:31:51 UTC] PHP Fatal error: Cannot redeclare class phpmailerException in /home/xxxxx/public_html/shop/wp-includes/class-phpmailer.php on line 4040

    I have restarted Apache, so a little lost on this one.

    Best regards

    Nigel

    • This reply was modified 5 years, 6 months ago by nigelh. Reason: correction on memory limit reported
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.