Home Forums Newsletter Plugin Support All Image links broken after switching site to SSL

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #72835
    BretFX
    Participant

    After completely switching my site to https in wordpress and enabling SSL cert, the images in my old emails are broken, as well as my new emails.

    When I create the email, and choose the images from Media, it lists the jpegs with https, so everything seems to be all https but no luck. Emails have no images, just the little question mark.

    Web host, site ground, can’t figure it out. Everything else ssl seems to be fine.

    Any ideas? I can’t email my customers until I figure this out.

    #72847
    Stefano
    Keymaster

    Try to get the link of an image an load it in a browser to see if it works or give back some kind of error. Old emails does not work if you have not setup a full redirect from http to https.

    Stefano.

    #72853
    BretFX
    Participant

    I think you’re on to something. If I open the email in a web browser, it looks just fine. But then if I right click an image and try to open it on it’s own, I get this error…

    403 – Forbidden Error
    You are not allowed to access this address.
    If the error persists, please contact the website webmaster.
    If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.

    Common reasons for this error are:

    Incorrect file/directory permissions: Below 644.
    In order files to be read by the webserver, their permissions have to be equal or above 644. You can update file permissions with a FTP client or through cPanel’s File Manager.

    Restrictive Apache directives inside .htaccess file.
    There are two Apache directives which can cause this error – ‘Deny from’ and ‘Options -Indexes’.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
×