Home Forums Newsletter Plugin Support Advanced Import is not importing

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #268238

    Hello
    Thanks for a great plugin. I’m currently testing it on my client’s website, and consider recommending to buy a premium licence. However, before doing that, I need to make sure that the plugin delivers what the client needs.

    At the moment, I have a problem with the Advanced Import extension: I can’t import anything.
    I tried with a CSV file (UTF8 format), I could map the fields, but when I click import, after I confirm, nothing happens (zero import, but no error message).
    I tried with a very basic CSV file containing only 1 email address and no other information, same result.
    I also tried with the “import from list” option, same result.

    I don’t understand what I’m doing wrong here.
    I have already imported users (with the list option, not the CSV file option) before the import feature was moved into an extension, it was working.

    Thank you in advance for your help.

    #268245
    bego
    Participant

    Partly same here. When testing, some few imports – basically name, first name, email – worked, everything else rather erratic and no guidance after input error. 🙁

    #268256
    bego
    Participant

    The Newsletter Team just pushed an update (Version 1.1.6), but unfortunately, I don’t see what changed. Are there release notes somewhere?

    #268265
    Stefano
    Keymaster

    Please check on status panel if you can see any logs from the import addon. Let me know if there are entries n those files.

    #268267
    bego
    Participant

    Grazie for looking into this.

    I only see a ‘Newsletter’-log file with old stuff in it. No logs from the Import addon.

    In the meantime, I made some import trials, in particular, I exported a CSV file, amended some lines in it, and reimported the whole CSV file with the “Update” setting. Result: Mostly worked, but only if one of the fields that can be explicitly mapped are affected. Everything else fails. In particular, I could not change the list settings (in the CSV-file “0” or “1” per list columns), as I had hoped for and which is essential to me.

    #268268
    bego
    Participant

    And by the way, the whole import process is very obscure for the user and would very much benefit from some more explanation of what is really going on.

    #268292
    info@mediasmart.de
    Participant

    Hello, I have the same problem with the Advanced Import addon. I also almost tried everything, but no addresses are imported. It worked before the extension.
    Thank you for your help!

    #268301

    I’m not sure we have the same problem: nothing at all is imported, in my case.

    #268302

    Thank you Stefano.
    I checked the logs, but there’s nothing there from the import extension…

    Is there any way to use the old import method, or to revert the plugin back to the previous version? I have a lot of imports to do for an urgent mailing and I regret having done the update…

    #268306
    bego
    Participant

    @Stefano (see my post yesterday 10.47pm):

    I only see a ‘Newsletter’-log file with old stuff in it. No logs from the Import addon.

    After rebooting everything, I found the following entry at the very end of the log file named “import-2021-03-673b578a.txt (258 kB)”:

    15-03-2021 21:36:04 – FATAL – v: 7.0.7 – m: 27,5 MB, u: 4 – Ivalid email on line xx@ssg@rr,error,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

    That seems alright since I continued toying around with the Import addon and wilfully provoked an expected failure: trying to import a subscriber with the (ostensibly erroneous) email address xx@ss@rr.

    #268676
    info@mediasmart.de
    Participant

    I sill have the problem. Nothing at all is imported. Did anyone find a solution?

    #268729

    I have used today the Advanced Import, everything was fine, no problems found.

    #268730

    I have used the Advanced Import today, everything was fine, I had no problems. Maybe you just have to check the csv file in some editor.

    #268786
    Misty Rudkin
    Participant

    Sorted.

    Either CSV file or copy&paste, the advanced import needs header.

    Email;Last name;First name;City
    stefano@thenewsletterplugin.com;Lissa;Stefano;Roma
    misty@rudkin.com;Misty;Rudkin;Roma

    It needs all 3 lines.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.