Home Forums Newsletter Plugin Support Unable to activate the Newsletter plugin…

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #9228

    Dear Stefano Lissa,

    I heard from a friend that the Newsletter plugin for WordPress is very good, and I decided to use it for my site. Unfortunately I couldn’t activate it. At first I thought it was the current theme or modifications I made, so I created a fresh-new WordPress site and installed the Newsletter plugin through “Plugins -> Add new -> Search”.

    But when I clicked on Activate, again an error message was displayed to me: “Plugin could not be activated because it triggered a fatal error.” I checked my Apache log for errors, and there are messages like:
    WordPress database error Table 'test2.wp_newsletter' doesn't exist for query alter table wp_newsletter convert to character set utf8 made by activate_plugin

    I tried this a lot of times, on fresh installations of WordPress and I don’t know what am I doing wrong?

    Thank you 🙂


    On some systems there is that problem, that will be patched on next version. Disable the wp_debug of wordpress, if active, but sometime is the wordpress configuration that make that message bubble out while it should be blocked by newsletter.

    Be patience still some days and I’ll release the patched version (or at least I hope that patch will be the solution to this problem).


    Hi Stefano,

    the wp_debug is set to false, so it must be another configuration option. It seems that the error message is shown only the first time I try to activate the plugin, because I tried again and it was successfully activated. Then I created a newsletter and a subscriber, but the newsletter was not delivered.

    I checked “Diagnostics” -> “Semaphores and Crons” tab -> “Delivery Engine” -> “Runs in 0 days, 0 hours, 0 minutes, 5 seconds”. So I guess that the delivery engine is OK. But under the “Newsletter delivery” on the “Semaphores and Crons” tab, it says “Not set” …

    I waited 30 minutes, but nothing happened. I clicked “Trigger now” on the delivery engine – still nothing. I clicked “Send now” in the newsletter, and it wasn’t sent. I checked the spam folder – no letters. So the newsletter status is still “new” and I don’t receive the e-mail. What should be the proper value of “Newsletter delivery”?



    Hi, first open your newsletter which is listed as new and press the send button. It should change and be listed as sending. This is the first step. Otherwise it’s not possible to test the delivery engine.

    Be sure to make a test from the diagnostic panel as well.



    When I open the newsletter and press the send button, it is sent and I receive it, and it is listed as sent. The “Trigger now” from the diagnostics panel doesn’t work. I have no idea what could be the problem.


    I tried “Send an email with WordPress” and “Send few emails with Newsletter” options from the diagnostics panel, and all the emails were sent, and I received them. Just the “Delivery Engine” doesn’t seem to work.


    The trigger now only trigger the delivery engine BUT if it’s stopped, otherwise it may just send the trigger notice and the delivery engine can ignore it.

    Did you set up the cron call? See the delivery engine documentation on my site.


    Hi Stefano,

    I saw the delivery engine documentation on the site, and I could verify that wp-cron is working. I am running my site on localhost (have not deployed it in public yet), so I manually called cron by visiting localhost/mySite/wp-cron.php

    The newsletter e-mails are sent, but only when their status is ‘sending’. But when I create a newsletter through the UI, its status is ‘new’… When does it go into ‘sending’ status?


    On the newsletter editor, simply press the button “send”.


    Ah, I understand. Yes, everything works perfectly now. Thanks 🙂

    Luk Kim Leung

    Dear Sir

    In the my diagnostic below, its seem everything ok, but In Semaphores, it is not set, also my newsletter’s status is still “new” which means have not been delivered

    even I pressed “Trigger the delivery engine”, so could anyone help me, thanks.

    Average scheduler activation interval 145 seconds/100 samples (OK) Reset
    Should be less than 300 seconds. Read more.

    WordPress Cron System ENABLED. (it’s ok)
    WordPress schedules weekly – 604800 s
    newsletter – 300 s
    newsletter_weekly – 604800 s
    hourly – 3600 s
    twicedaily – 43200 s
    daily – 86400 s
    Delivery Engine Runs in 0 days, 0 hours, 0 minutes, 43 seconds Trigger now
    If inactive or always in “running now” status your blog has a problem: read more here.

    Sending statistics Still not enough data.
    WP transients OK

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.