Home Forums Newsletter Plugin Support sign up takes around 2 minutes!

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27171
    bwragg
    Participant

    Hi,

    I have a problem with the plugin. When I do a signup on either the widget or via the normal form, when I submit the form it takes about 1.5-2 minutes before I get the “Thanks for subscribing xyz” page.

    I turned on debugging and this is what the log says (names and emails have been changed):

    15-11-2016 06:07:07 – DEBUG – m: 25.5 MB, u: 1 – Replace start
    15-11-2016 06:07:07 – DEBUG – m: 25.5 MB, u: 1 – Replace end
    15-11-2016 06:07:07 – DEBUG – m: 25.5 MB, u: 1 – Replace start
    15-11-2016 06:07:07 – DEBUG – m: 25.5 MB, u: 1 – Replace end
    15-11-2016 06:07:13 – DEBUG – m: 25.3 MB, u: 1 – Replace start
    15-11-2016 06:07:13 – DEBUG – m: 25.3 MB, u: 1 – Replace end
    15-11-2016 06:07:13 – DEBUG – m: 25.3 MB, u: 1 – Replace start
    15-11-2016 06:07:13 – DEBUG – m: 25.3 MB, u: 1 – Replace end
    15-11-2016 06:07:13 – DEBUG – m: 20.2 MB, u: 0 – hook_newsletter> Start
    15-11-2016 06:07:13 – DEBUG – m: 20.2 MB, u: 0 – hook_newsletter> Emails found in sending status: 0
    15-11-2016 06:07:13 – DEBUG – m: 20.2 MB, u: 0 – hook_newsletter> End
    15-11-2016 06:07:32 – DEBUG – m: 20.2 MB, u: 1 – mail> To: myadminemail@somewhere.com
    15-11-2016 06:07:32 – DEBUG – m: 20.2 MB, u: 1 – mail> Subject: [XYZ Centre] Newsletter subscription
    15-11-2016 06:08:06 – DEBUG – m: 20.3 MB, u: 1 – Replace start
    15-11-2016 06:08:06 – DEBUG – m: 20.3 MB, u: 1 – Replace end
    15-11-2016 06:08:06 – DEBUG – m: 20.3 MB, u: 1 – Replace start
    15-11-2016 06:08:06 – DEBUG – m: 20.3 MB, u: 1 – Replace end
    15-11-2016 06:08:06 – DEBUG – m: 20.4 MB, u: 1 – Replace start
    15-11-2016 06:08:06 – DEBUG – m: 20.4 MB, u: 1 – Replace end
    15-11-2016 06:08:06 – DEBUG – m: 20.4 MB, u: 1 – mail> To: subscribersemail@somewhereelse.com.au
    15-11-2016 06:08:06 – DEBUG – m: 20.4 MB, u: 1 – mail> Subject: Welcome aboard, subscribers name
    15-11-2016 06:08:43 – DEBUG – m: 24.5 MB, u: 1 – Replace start
    15-11-2016 06:08:43 – DEBUG – m: 24.5 MB, u: 1 – Replace end

    Notice the long pauses. I’m using SMTP under Settings->SMTP

    Any ideas?

    Thanks

    #27172
    bwragg
    Participant

    Figure it out.

    In case it helps someone else, we are sending mail via a Microsoft SMTP server. My tech admin turned the maxacknowledgementdelay off and it fixed it.

    Regards

    #27179
    Stefano
    Keymaster

    The problem is the connection with the SMTP. This is the only possible explanation. Check it.

    Stefano.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
×