Home Forums Newsletter Plugin Support Sending to 200,000+ subscribers

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #11923
    Anonymous
    Inactive

    We’re looking to implement this plugin for our newsletter needs. Currently we have over 200,000 subscribers. Our first newsletter took about 7 days to send to everyone.

    Looking through the logs set to Debug it appears that our web-server’s maximum delivery speed is about 1320 emails per hour. Setting a higher setting shows a “Max execution time limit reached” message in the log and it does not increase the delivery speed.

    Is there anything we can do to speed this process up? It appears that the plugin can only generate an e-mail every 2-4 seconds.
    We are using an SMTP server in the local network of the webserver which does not contain any sending limitations. Cron is enabled and appears to be working properly with the delivery engine.

    The following are our PHP / WordPress settings:

    Max e-mails per hour: 1320
    PHP max execution time: 315
    PHP Memory Limit: 256M
    WordPress Memory limit: 256M

    Here is an excerpt from the debug log:
    25-09-2014 19:33:44 – DEBUG – 11.6 MB – mail> To: ************@******
    25-09-2014 19:33:44 – DEBUG – 11.6 MB – mail> Subject: **************
    25-09-2014 19:33:45 – DEBUG – 10.4 MB – hook_newsletter> End
    25-09-2014 19:34:14 – DEBUG – 10.2 MB – hook_newsletter> Start
    25-09-2014 19:34:15 – DEBUG – 10.2 MB – hook_newsletter> Emails found in sending status: 1
    25-09-2014 19:34:15 – DEBUG – 10.2 MB – hook_newsletter> Sending email 11
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – limits_exceeded> Setting the limits for the first time
    25-09-2014 19:34:15 – INFO – 11.4 MB – limits_exceeded> Max time set to 299
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – limits_exceeded> Max number of emails can send: 110
    25-09-2014 19:34:15 – DEBUG – 11.3 MB – Replace start
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – Replace end
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – Replace start
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – Replace end
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – Replace start
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – Replace end
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – mail> To: *******@*******
    25-09-2014 19:34:15 – DEBUG – 11.4 MB – mail> Subject: **************

    Let me know if I need to supply any more information.

    Thank You

    #11925
    Stefano
    Keymaster

    Every PHP process can stay for at most the “execution time limit” set on php.ini. From the log I see the time used by newsletter is 299 seconds, 5 minutes. So you cannot do more than that, probably your server cannot send more than 1300 email in 5 minutes.

    1300 emails in five minutes are 4 email per second… even is the SMTP server si in the local network, that is not a bad value… you should have better result installing an SMTP in the web server in smarthost mode, so it receive and enqueue the emails and the deliver them to the SMTP server. That can be a more efficient configuration since the local SMTP can be quicker in sending tons of emails.

    Bye, Stefano.
    Already tried Nearby Photos? Try it and see what’s happening around you!

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
×