Home Forums Newsletter Plugin Support Search of Forum & Archive-Extension

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #19273
    martins
    Participant

    Dear Stefano,
    I have downloaded, installed and activated the “[newsletter_archive]”, but when I go to the page with the short-code, only the shortcode is displayed.
    My situation is this:
    1) I have quite a number of old Newsletters, these don’t display
    2) I have not sent out a newsletter since installing the newsletter_archive plugin
    3) I have Newsletter Plug-in Version: 4.0.6
    4) I have Newsletter-Archive Plug-in Version: 2.2.3
    5) The short code I’m using is:
    [newsletter_archive]
    This is our newsletter archive…
    [/newsletter_archive]

    regards,
    MartinS

    #19274
    martins
    Participant

    I have looked at the documentation, and I have entered the Short-Codes (without the “Inside Spaces”, as directed, (but this time in the “text” rather than the “Visual” view), This helped, since that webpage now lists the Newsletters, but when I click on them the page creates a window on that page, of the HomePage, but also with the WordPress Message as below:
    ==========================================================================================================
    This is somewhat embarrassing, isn’t it?

    It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.
    Search
    Most Used Categories

    No categories

    Archives

    Try looking in the monthly archives. 🙂
    Archives
    Tags
    ==========================================================================================================

    #19275
    martins
    Participant
    #19360
    Stefano
    Keymaster

    On my broser that link works, I can see the newsletter embedded in a iframe, as it should be.

    #19369
    martins
    Participant

    Dear Stefano, The Newsletter links are broken in FireFox, Chrome and IE. What browser are you using?

    The links look like they work, but (for example) the first Newsletter (Glenthorne – Special Invitation), should read as below between the lines, but instead, though it does display the header photo, the content of the Newsletter doesn’t appear, but says “This is somewhat embarrassing…… ” as stated above.
    regards, martin
    ================================================================================
    Dear {name} {surname},
    The Australian Plants Society have extended to us an invitation to visit the property of one of their members, Greg Kirby,
    The main focus of the visit will be the establishment of a native grass area and its management.

    When: Sunday 1st November, (This Sunday) from 11 am.
    Where: 87 Oakridge Rd, Chandler’s Hill ( UBD p.166 P 11 )

    Tours will be at 11am and 2pm and people are welcome to attend either tour and are welcome to bring a picnic lunch to eat after the first tour or before the second tour (and to enjoy a chat together).
    ================================================================================

    #19372
    martins
    Participant

    Dear Stefano,
    When a Newsletter is sent out, I include the short-code {email_url}, which gives the URL as the following:
    http://www.friendsofglenthorne.org.au/wp-content/plugins/newsletter/do/view.php?id=66 << This displays correctly, (but on its own page, not in an “iframe”.

    However, on the “Archive” page, the URL for the same newsletter is:
    http://www.friendsofglenthorne.org.au/news-letter/?email_id=66
    When this is rendered into an <iframe> on the page (See the Page Source of the Archive Listings) the “src” of the <iframe> doesn’t seem to be found, and so displays the “This is somewhat embarrassing . . .”. This newsletter-archive URL (from the page source) is:

    http://www.friendsofglenthorne.org.au/wp-content/plugins/newsletter-archive/view.php?email_id=66

    Also, an email that will not exist, is email_id=68, so
    http://www.friendsofglenthorne.org.au/wp-content/plugins/newsletter/do/view.php?id=67 does display, “Email not found”, but
    http://www.friendsofglenthorne.org.au/wp-content/plugins/newsletter-archive/view.php?email_id=66 does not display the “Email not found” output of the php file

    #19460
    Stefano
    Keymaster

    Is this file present in your blog: /wp-content/plugins/newsletter-archive/view.php? And can it be executed as PHP (you should ask the provider)?

    And, yes, I wrongly believed the iframe was displaying your newsletter.

    #19465
    martins
    Participant

    Dear Stephano, I appreciate you help.
    I’m not sure what you mean by “can it be executed by PHP?”.
    The permissions on that file are 0664 (-rw-rw-r–), but so are all the other files.
    In wp-content/plugins/newsletter/do directory, ALL the files are 0644 (-rw-r–r–)

    I have just noticed that in the WP Plugin Editor, when I edit a *.php plug-in file, the heading changes (active/inactive) for different files. eg.
    Editing newsletter-archive/archive.php (active)
    Editing newsletter-archive/view.php (inactive)
    However, the file permissions for these two files are the same (0664), so I’m not sure what triggers the “active” or “inactive” heading.
    Also, both “newsletter” and “newsletter-archive” directories have permissions 0755 (newsletter-archive was “0775”, but changing it made no difference!)
    regards,
    martin

    #19483
    Stefano
    Keymaster

    Actually it can be a folder permissions problem which do not enable apache to “see” that file… maybe..

    #19649
    martins
    Participant

    In particular, which folder do you mean? What I mean is, all the rest of the website hasn’t a problem.
    Are you saying that the plug-in works on your server Ok?

    The “This is embarrassing” page is embedded in the “Newsletter” page, but if I go to that URL directly, it also can’t be viewed. The URL is:
    http://www.friendsofglenthorne.org.au/wp-content/plugins/newsletter-archive/view.php?email_id=67

    In the Database, email_id #67 exists, and each folder in wp-content/plugins/newsletter-archive/ has read permissions (It must be a Linux webserver, since the permissions are at least 644.

    Do you have an example website with the “Newsletter-Archive” plugin is actually working, so I can view the newsletters on that one?

    regards,
    martin

    #20775
    martins
    Participant

    Dear Stefano,
    I hope you have not forgotton about my problem above.
    I have created a “Test” page on our website. (Since this plugin doesn’t work yet, but we want to be able to test it)
    It is here: http://www.friendsofglenthorne.org.au/newsletter-test/

    Each of the links, on the [newsletter-archive] page are like this:
    http://www.friendsofglenthorne.org.au/newsletter-test/?email_id=68 (1)

    But, when you send an email out, the link for that same newsletter is the following, and this link does work!!!
    http://www.friendsofglenthorne.org.au/wp-content/plugins/newsletter/do/view.php?id=68 (2)

    So, the [newsletter-archive] page should have all the links as (2) above, rather than (1) above.
    Are you able to help me with where this code is, in the Plug-in code?
    regards,
    martin

    #20776
    martins
    Participant

    Dear Stefano,

    My apologies. The WordPress Plug-in site does not have the latest version of Newsletter-Archive (extension) (which is version 4.0.0)
    I have manually upgraded to version 4.0.0, and the links now work perfectly.

    kindest regards,
    martin

    #243604
    Anonymous
    Participant

    Hi,
    I can correctly display the newsletter archive on my page. But when I want to navigate through the content inside the newsletters in the archive using the search box, it doesn’t show me real content rather it shows the shortcode.

    In short, I want search box to show me the content of the archived newsletters.
    is that possible?

    Thank YoU

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.