Home Forums Newsletter Plugin Support Not able to save Posts Block

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26337
    Anonymous
    Inactive

    I am currently facing an issue that I have yet to be able to resolve.

    I drag and drop either the “Blog Posts” or “Post Columns” block into my newsletter. I then try to edit its properties, selecting a new background color and adjusting adjusting the number of posts, I then click “Save”. Once I do that, the block disappears.

    Here are some things I have tried to resolve it:

    – Tested existing and new newsletter, issue happens with all.
    – Deactivated and reactivated the plugin.
    – Uninstalled and reinstalled plugin

    I then searched the Apache error logs and found the following errors occurring each time I save the block:

    [Thu Oct 13 15:44:54 2016] [error] [client 10.20.4.98] PHP Warning: include(/home/srt/public_html/wp-content/plugins/newsletter/emails/tnp-composer/blocks/content-07-twocols.php): failed to open stream: No such file or directory in /home/srt/public_html/wp-content/plugins/newsletter/plugin.php on line 1511, referer: http://srt.liquidweb.com/wp-admin/admin.php?page=newsletter_emails_composer&id=20

    I checked the directory it is mentioning and the files that exist there are as followed:

    [srt@cent67 blocks]$ ll
    total 104
    -rw-r--r-- 1 srt srt 4052 Oct 13 15:46 content-01-hero.block.php
    -rw-r--r-- 1 srt srt 2713 Oct 13 15:46 content-01-hero.block.png
    -rw-r--r-- 1 srt srt  714 Oct 13 15:46 content-02-heading.block.php
    -rw-r--r-- 1 srt srt 2585 Oct 13 15:46 content-02-heading.block.png
    -rw-r--r-- 1 srt srt  897 Oct 13 15:46 content-03-text.block.php
    -rw-r--r-- 1 srt srt 1630 Oct 13 15:46 content-03-text.block.png
    -rw-r--r-- 1 srt srt 1391 Oct 13 15:46 content-04-cta.block.php
    -rw-r--r-- 1 srt srt 3267 Oct 13 15:46 content-04-cta.block.png
    -rw-r--r-- 1 srt srt  769 Oct 13 15:46 content-05-image.block.php
    -rw-r--r-- 1 srt srt 2578 Oct 13 15:46 content-05-image.block.png
    -rw-r--r-- 1 srt srt 5674 Oct 13 15:46 content-06-posts.block.php
    -rw-r--r-- 1 srt srt 5396 Oct 13 15:46 content-06-posts.block.png
    -rw-r--r-- 1 srt srt 8106 Oct 13 15:46 content-07-twocols.block.php
    -rw-r--r-- 1 srt srt 3334 Oct 13 15:46 content-07-twocols.block.png
    -rw-r--r-- 1 srt srt 1171 Oct 13 15:46 footer-01-footer.block.php
    -rw-r--r-- 1 srt srt 2050 Oct 13 15:46 footer-01-footer.block.png
    -rw-r--r-- 1 srt srt 1145 Oct 13 15:46 footer-02-canspam.block.php
    -rw-r--r-- 1 srt srt 2472 Oct 13 15:46 footer-02-canspam.block.png
    -rw-r--r-- 1 srt srt 4261 Oct 13 15:46 footer-03-social.block.php
    -rw-r--r-- 1 srt srt 3150 Oct 13 15:46 footer-03-social.block.png
    -rw-r--r-- 1 srt srt 2409 Oct 13 15:46 header-01-header.block.php
    -rw-r--r-- 1 srt srt 2574 Oct 13 15:46 header-01-header.block.png

    Any help would be appreciated. I did try copying the file “content-07-twocols.block.php” to “content-07-twocols.php”, which the error did stop but then making any changes to the post blocks would save.

    #26353
    Roberto
    Keymaster

    Hi, sorry for the inconvenience, fixing in the upcoming 4.6.6 version.

    Regards,
    Roberto

    #26469
    Anonymous
    Inactive

    Any ETA for next version?

    Thanks,

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
×