Home Forums Newsletter Plugin Support Newsletter text broken in HTML version of emails after last update (may be)

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #285506
    BorysKuritsyn
    Participant

    Hi!

    After last update (I think) I have a huge problem with HTML version in any newsletter.

    All Cyrillic text in HTML letter looks totally broken while open letter on client side. Web version of newsletter opened as webpage completely normal.
    The problem is symbols ” (quotes) in newsletter HTML code look like 3D” (additional symbols 3 and D before opening quotes). I see this symbols in HTML code of emails,

    The problem persists in any email sent by Newsletter plugin, but not others plugins.
    Please advise how to fix this.

    #285511
    Stefano
    Keymaster

    Hi, have you installed an SMTP plugin?

    #285517
    BorysKuritsyn
    Participant

    Yes, I have WP Mail SMTP Pro installed to adjust sending via Amazon S3.
    Also I have SMTP Mailing Queue plugin to adjust sending params.

    Both these plugins were updated recently.

    But I can not imagine how this plugins can inflience to email content, or I’m wrong?

    #285819
    tsq
    Participant

    I have a similar issue, Stefano
    I signed up to my own newsletter and received a confirmation email notice full of html code inside the email

    In fact, my MESSAGES TEMPLATE, appears as html inside the welcome email. I use gmail.

    And when I tried to share the first few lines of that html code here, your wordfence blocked me….

    #285820
    tsq
    Participant

    and resetting the template did NOT help
    Changing the email address or using outlook to see the email also did not help

    The problem is not related to gmail or the software used and is not related to the template

    #285821
    tsq
    Participant

    BorysKuritsyn, Stefano is right, I disabled my PostSMTP plugin and the email now is fixed (the template is parsed)

    #285841
    BorysKuritsyn
    Participant

    But I have not PostSMTP plugin installed.

    #285844
    tsq
    Participant

    May 6, 2022 at 11:10 pm#285511REPLY

    Stefano
    Keymaster
    Hi, have you installed an SMTP plugin? <<< any SMTP plugin …….

    May 7, 2022 at 12:29 pm#285517

    BorysKuritsyn
    Participant
    Yes, I have WP Mail SMTP Pro

    #285845
    tsq
    Participant

    try disabling WP Mail SMTP Pro and send yourself a test from within the newsletter plugin

    #285854
    Stefano
    Keymaster

    Hi, please, we’re mixing up two conversations. Let’s stick to the first request.
    An SMTP plugin could be a problem as soon as it changes the mail content. Usually, that does not happen, but there are SMTP plugins that, for example, lose the content encoding breaking the final email.
    Another problem is when you send with GMAIL (using it as “mail server”), since GMAIL strips away all HTML hidden parts added to help outlook in displaying correctly the email.
    The first problem reported seems connected to the SMTP plugin: it’s not the first time we find out SMTP plugins stripping some information from the original email.


    @BorysKuritsyn

    So let’s start from that point: which SMYP plugin is in use and which delivery service is it connected to?

    #285969
    BorysKuritsyn
    Participant

    @Stefano
    So let’s start from that point: which SMYP plugin is in use and which delivery service is it connected to? <<<—-

    As mentioned above, I have WP Mail SMTP Pro installed to adjust sending via Amazon S3.

    #285975
    Stefano
    Keymaster

    Ok, can you send a test newsletter to test [at] thenewsletterplugin.com so I can analyze the source? Can you send even a test from the delivery diagnostic panel under “System”?
    The newsletter was created with the Newsletter composer or in another way?
    Thanks!

    #285979
    Stefano
    Keymaster

    Hi, I received both the tests and with thunderbird and with outlook and gmail they look absolutely ok.
    Stefano.

    #285999
    BorysKuritsyn
    Participant

    @Stefano
    Hi, I sent two tests yesterday, and both were absolutely ok.
    It was surprise for Me.
    That`s why I created new Message from the scratch in Newsletter editor and made test again.
    And now I think You have a sample of problem in your mailbox.
    The newsletter was created with the Newsletter composer.

    #286003
    Stefano
    Keymaster

    I can see the broken messages. Which is the difference in the procedure your followed to create them?

    #286041
    BorysKuritsyn
    Participant

    @Stefano

    I created new Message from the scratch in Newsletter editor.

    #286042
    BorysKuritsyn
    Participant

    I have installed NEWSLETTER AMAZON SES INTEGRATION
    and problem gone.

    Is this plugin affect NEWSLETTER plugin only?

    As mentioned above, I use WP Mail SMTP Pro to log emails sending and adjust sending via Amazon SES.

    As far as i understand, WP Mail SMTP Pro affects on common wordpress configuration and NEWSLETTER AMAZON SES INTEGRATION affects Newsletter plugin only.

    #286043
    Stefano
    Keymaster

    Yes, our addon works only with the Newsletter plugin, all other emails (sent by other plugins) are delivered by WP and, with an SMTP plugin installed, via that plugin. Tere are two options: or wp smtp pro is changing in the wrong way the email content, for example changing the encoding, or the SMTP you connect with that plugin is making changes to the emails.
    If you used smtp pro to connect the blog to amazon ses, the problem probably is on wp smtp pro.

Viewing 18 posts - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.