Home Forums Newsletter Plugin Support Newsletter and Pie register

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #22211

    I use the newsletter plugin and pie register for registration. The newsletterplugin is set to force subscription on registration, which worked fine a while ago. But now new registered users are not subscribed in the list. This does not change when the user logs in for the first time which used to set the user on status confirmed. Anyone who knows a solution?


    Hi, or there is a bug on Newsletter or the pie registration changed something. I’ll check the Newsletter code. Try to check the wp integration panel of Newsletter: since we saparated that panel maybe the migration has not completed correctly in your installation.



    Hello Stefano,
    I got rid of pie Register to have my page working, everything works so far, users get subscribed on Registration and confirmed on fist Login.
    But I the customer gets this error after submitting a Registration:

    Warning: Illegal string offset ‘noconfirmation’ in /wp-content/plugins/newsletter/subscription/subscription.php on line 363

    Warning: Cannot modify header information – headers already sent by (output started at /wp-content/plugins/newsletter/subscription/subscription.php:363) in /wp-includes/pluggable.php on line 1171

    and a similar on first Login. But still the Newsletter plugin and Registration and Login in works, if you just reload the page.

    Thank you for any help


    I discovert a nother error, in the wordpress Backend under List Building whatever I Change or Input(text) on the different Tabs, for example text for a confimation email or forced preferences is not stored. If I leave the backend and return the changes are gone.

    Perhaps this has something to do with the error I reportet earlier.


    I discovered a work around. The error seems to come from the not saving some of the changes in the backend. So in the subscription.php there is no value in the variable ‘noconfirmation’ , I edited the subscription.php and replaced ‘noconfirmation’ with a 0 for double optin and the ‘notify’ with a 0 for no admin notification. Now it works. But this can only be a temporary solution. A permanent solution would be great.

    I’m thankfull for any suggestions

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.