Home Forums Newsletter Plugin Support New Problem with Subscription

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #20666

    Last month I build a Site with WordPress and Newsletter Plugin and all was fine.
    Since a few days, Subscription does not function.
    After fill in the Email and sendig there comes a site without theme – only the name of the website.

    And there is no Email send for confirmation.
    The adress is shown in backend under subscibers with unconfirmed.
    Smtp is correct – I think. I get the Test-Email.

    The WordPress Debug is true. I can see this Errormassages:
    `[10-Feb-2016 09:51:44 UTC] PHP Notice: Undefined index: scheduler_max in /customers/2/8/0/mydomain.de/httpd.www/wp-content/plugins/newsletter/plugin.php on line 131
    [10-Feb-2016 09:18:46 UTC] PHP Notice: Undefined index: nl in /customers/2/8/0/mydomain.de/httpd.www/wp-content/plugins/newsletter/subscription/subscription.php on line 506
    [10-Feb-2016 09:51:44 UTC] PHP Notice: Undefined index: editor in /customers/2/8/0/mydomain.de/httpd.www/wp-content/plugins/newsletter/includes/module.php on line 529
    [10-Feb-2016 09:51:44 UTC] PHP Notice: Undefined property: NewsletterControls::$messages in /customers/2/8/0/mydomain.de/httpd.www/wp-content/plugins/newsletter/main/main.php on line 52
    [10-Feb-2016 09:55:09 UTC] PHP Notice: Undefined index: already_confirmed_text in /customers/2/8/0/mydomain.de/httpd.www/wp-content/plugins/newsletter/includes/controls.php on line 431
    [10-Feb-2016 09:55:42 UTC] PHP Warning: array_merge(): Argument #1 is not an array in /customers/2/8/0/mydomain.de/httpd.www/wp-content/plugins/newsletter/includes/module.php on line 192
    [10-Feb-2016 10:04:46 UTC] PHP Notice: Uninitialized string offset: 0 in /customers/2/8/0/mydomain.de/httpd.www/wp-content/plugins/newsletter/subscription/subscription.php on line 457
    [10-Feb-2016 10:06:44 UTC] PHP Notice: Undefined index: alert in /customers/2/8/0/mydomain.de/httpd.www/wp-content/plugins/newsletter/subscription/page.php on line 22

    I asked the hoster for Error-Log from Apache, but it is not possible here.

    I installed new WordPress 4.4.2 and newest newsletter Plugin. But this does not solve the problem.

    What can I do?


    Hi, check if the confirmation messages are correctly set and the messages template panel to see if a custom template is active and maybe empty. If so disable it or reset it.


    The confirmations Messages are set correctly.

    Where is the Messages Template Panel to see, if a custom Template is active?
    Can please you give me the link ?

    Here are the System Parameters, are they OK?

    Database Wait Timeout	300 (seconds)
    PHP Execution Time	50 (seconds)
    PHP Memory Limit	256M
    WordPress plugin url	http://www.mydomain.de/wp-content/plugins 
    Filters: no filters attached to "plugin_urls"
    This value should contains the full URL to your plugin folder. If there are filters attached, the value can be different from the original generated by WordPress and sometime worng.
    Blog Charset	UTF-8
    WordPress Memory limit	40M
    WP_DEBUG	true
    Absolute path	/customers/2/8/0/mariannevoit.de/httpd.www/
    Tables Prefix	wp_
    Database Charset and Collate	utf8mb4
    Action file accessibility (obsolete)	OK
    If this internal test fails, subscription, confirmation and so on could fail. Try to open this link: if it reports "ok", consider this test as passed.
    File permissions (obsolete)	OK

    Now I know what is causing the problem:
    The information here will be lost:
    Above all, the link to the page where the shortcut[newsletters] is.
    I thought yesterday, that it is a consequence of the update and have filled it out again.
    But this morning the data where lost again.
    I have it filled it again, and now the confirmation page appears correctly and also confiramtion E-mail is sent.
    But it’s not a good feeling, because I do not know what is wrong and what I have to do to avoid the behavior.


    This is a very odd behavior in your blog. The php memory limit set to 40M is very low for a modern blog, I suggest you to ask the provide to increase it to at least twice that value. An out of memory could be the problem.


    Ok, Thankyou, I will ask for more memory.


    OK Thankyou.
    I set define(‘WP_MEMORY_LIMIT’, ‘124M’);

    Lets try….
    But there was no error like “Fatal error: Allowed memory size…”

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.