Home Forums Newsletter Plugin Support Links in Newsletter now in SSL/https?

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #16019
    newsfish
    Participant

    Hi Stefano,

    today I sent a Feed by Mail newsletter as every week, but today all links in the newsletter-email where SSL, with https. But I only use SSL in the WordPress backend, see wp-config.php:

    define(‘FORCE_SSL_ADMIN’, true);

    I did not change anything in my blog except for an update of the newsletter plugin last week.

    After the newsletter was sent today I tested it again with the test option in Feed by Mail and in that email there were no SSL-links any more, except the featured image of my article.

    That’s really strange. Why is that? Thanks.

    #16020
    Stefano
    Keymaster

    Uhm, this is strange because the email is generated in a “non-admin” context so that define should not affect the creation of the message. Tests messages are generated in the admin context and it’s strange to have them with non-https links.

    More: the unsubscription or profile link are https? Or only the post and image links?

    Stefano.

    #16023
    newsfish
    Participant

    All links and image-sources were https in the real newsletter email, in the testmail only the image-source was. Really strange, because I have another 2 blogs which do not have this issue and they are all on the same versions and also have admin-SSL.

    Should the test-email have SSL links?

    Is SSL the cause because the preview of the newsletter does not work any longer?

    #16030
    Stefano
    Keymaster

    Hi, how is set your blog address on wordpress general configuration panel?

    #16031
    newsfish
    Participant

    It’s both with “http://”

    #16032
    newsfish
    Participant

    For your interest: I use a self signed certificate. With the plugin “backup wordpress” I get this message in the plugin settings:

    “wp-cron.php is returning a SSL certificate problem: self signed certificate response which could mean cron jobs aren’t getting fired properly. BackUpWordPress relies on wp-cron to run scheduled backups. See the FAQ for more details.”

    So could this also affect your use of cron?

    But I need to mention that on all of my blogs I use a self signed certificate, but only with this one blog I got the SSL-link-newsletter.

    #16033
    Stefano
    Keymaster

    Uhm, the problem is that wp-cron.php is called with https and that probably create a problem when generating the email. If you call manually the wp-cron.php with http, does it works? If so you can desable the auto wp-cron.php call and trigger the cron externally. See the delivery engine documentation on this site for examples.

    Keep me updated, thank you!

    Stefano.

    #16034
    newsfish
    Participant

    It (manual call of cron with http) does work. But I wonder why this is only an issue in one of several blogs with newsletter plugin?

    • This reply was modified 7 years, 3 months ago by newsfish.
    #16037
    Stefano
    Keymaster

    I don’t know, maybe there is a plugin other than the define, that detects the https call and forces the https on every generated link?

    #16038
    newsfish
    Participant

    I don’t know, but I use SSL since some weeks without any problems. Could this be an issue with WP 4.2 and newsletter plugin or do you have any other idea? The manual cron works, but it is not a really good solution.

    #16039
    Stefano
    Keymaster

    Hi, the externally triggered cron is the best solution ever for WordPress. Actually WordPress does a trick that relies on site traffic to keep the cron system working. I don’t know if it is a 4.2 problem.

    #17024
    newsfish
    Participant

    Hi Stefano,

    yesterday my WordPress updatet to version 4.2.4. Today all links in the newsletter-email redirect to https, which brings all users a certificate warning.

    The newsletter-links themself all are http, but the newsletter-plugin redirects them to https. The normal site use does no redirect.

    Now I disabled the cron also in this blog and hope, that the problem is solved with my next newsletter. The strange thing is: Another blog with 4.2.4 and the newsletter-plugin does not have this issue. Both blogs use
    define(‘FORCE_SSL_ADMIN’, true);

    Is the https-redirect stored in the database or why is there still a http to https redirect even if I disable this ssl-define?

    Thanks.

    #17045
    Stefano
    Keymaster

    Uhm, Newsletter just build link asking wordpress for a base url. Are the traking link containing the https?

    #17054
    newsfish
    Participant

    No, the URL in the emails are http, not https. But the plugin redirects them to https.

    #17056
    Stefano
    Keymaster

    @newsfish can you send me a starting link which redirects in https? privately at stefano@thenewsletterplugin.com

    #17157
    settlersoman
    Participant

    Hi guys,

    this is not a new problem. I have faced this problem since I installed the newsletter plugin (hmmm 6-8months ago). I don’t know why but newsletter (on my blog) use https in my posts and because I use self-signed certificate on my site, I have to switch to HTML source and change all https to http – I can avoid any problems on my readers side (like… why this site is not secured…) However I have to turn off tracking because it doesn’t work after changing https to http.

    The problem is the same even with this option define(‘FORCE_SSL_ADMIN’, true); or without.

    Any clue? I would like to use http by default with tracking…

    #17158
    settlersoman
    Participant

    .

    #17160
    Stefano
    Keymaster

    Hi, but the wordpress general setting, which kind of url shows? http or https on blog and home configurations? Are you using ssl only on admin side?

    #17161
    settlersoman
    Participant

    Hi Stefano,

    I use http on home configuration. https is used only on admin site.

Viewing 19 posts - 1 through 19 (of 19 total)
  • You must be logged in to reply to this topic.