Home Forums Newsletter Plugin Support Forum & instead of &

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6628
    ice
    Member

    When subscribing or when clicking on the profile link in the newsletter the url reads like this:

    ?page_id=4&nk=84-2d73dc3c09

    Or with the profile link:

    ?page_id=4&nm=profile&nk=3-b02f1a922a4bdb1470c1e4bee15f25a1

     

    Why is & replaced with & ??

    #6629
    Stefano
    Keymaster

    Really they are correct if you use them on a real A tag, while if added as-is in a page they can be wrong.

    I cannot distinguish the two cases, I’ll look at it to use only the non standard ampersand.

    Stefano.

    #6665
    ice
    Member

    Hi Stefano,

    sorry for not being clear enough. When the subscriber gets a newsletter the url pointing to the subscribers profile page looks like this:

    http://www.mywebpage.com/?page_id=4&nm=profile&nk=3-b02f1a922a4bdb1470c1e4bee15f25a1

     The & is replaced with &. Which makes the link not working..

    And when a user is subscribing to the newsletter he or she is sent to this url:

    http://www.mywebpage.com/?page_id=4&nk=84-2d73dc3c09

    It worked before but after some updates I noticed it was not working anymore..

    Why is there an & in the url? Its an automated one that I don’t make.. Its the redirection from the login form and the url to the profile page in the newsletter.

     

    Many many thanks in advance!
    And you bet I will donate some money when this problem is solved! 🙂

    Thanks again!

    #6666
    Stefano
    Keymaster

    Hi, there is a bug for sites which do not use permalinks. I have already found in one place an I’m checking if the problem is on other places.

    I’ll try to fix it tomorrow.

    The is an &amp in excess in your case, after I’ll checked the code I can understand better the problem.

    Stefano.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.