Home Forums Newsletter Plugin Support Increase sender speed

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #15022
    ikaroweb
    Participant

    Hi,
    How can increase sender speed with my server ?
    In 12 hours were sent 56.000 mail, i think is to little.

    Thanks in advance.

    Ika

    #15036
    Stefano
    Keymaster

    Did you change the delivery speed on main newsletter page? Enable the log to info level on diagnostic panel and look at the logs file on wp-content/logs/newsletter: if there is a “limit reached” we can check further few options for your server configuration.

    Stefano.

    #15041
    ikaroweb
    Participant

    In delivery speed i’ve set 10000.
    Whick level i’ve to enable ? normal/error/debug ?

    05-02-2015 10:45:32 - INFO - 13,5 MB - limits_exceeded> Max time set to 285

    • This reply was modified 7 years, 10 months ago by ikaroweb. Reason: log
    #15043
    Stefano
    Keymaster

    Normal should be enough.

    #15044
    ikaroweb
    Participant

    Ok!
    Have you saw my log ?

    05-02-2015 10:45:32 - INFO - 13,5 MB - limits_exceeded> Max time set to 285

    #15059
    Stefano
    Keymaster

    You’re are hitting your server capability. Since the max time is set to 285 seconds, it means you php timeout is the to 300 seconds exactly the maximum run time for a Newsletter batch. Are you using an external SMTP?

    #15060
    ikaroweb
    Participant

    No i’ve a vps and use mail.

    #15061
    Stefano
    Keymaster

    Hi, the numbers you’re reporting seem to reveal a max of 1 email per second. Usually this happens when using an external SMTP or when the local SMTP has not a queue configured. Locally you probably have sendmail or postfix or exim: are they configured to send the email directly or as smarthost connecting to an external SMTP?

    #15062
    ikaroweb
    Participant

    I’ve installed postfix to send email directly without and external SMTP.

    #15063
    Stefano
    Keymaster

    Ok, I use postfix in my servers as well. You should be able to have better performances since postfix queues mails and then deliver them. Have you setup a cron call to the wp-cron.php page every five minutes?

    https://www.thenewsletterplugin.com/plugins/newsletter/newsletter-delivery-engine

    #15064
    ikaroweb
    Participant

    No i’ve not!
    It’s that the problem ?

    #15066
    Stefano
    Keymaster

    Could be. WordPress, being PHP based, cannot schedule in a realible way the internal jobs execution. So it should be triggered externally.

    Setup a cron wget call to the wp-cron.php page and you can even disable the internal cron call (refer the documentation page). Probably that helps in having a greater speed.

    #15067
    ikaroweb
    Participant

    A wget cron or a php cron to run the wp-cron.php ?

    #15068
    ikaroweb
    Participant

    Ok so i need to setup a wget cron or a php cron to execute wp-cron.php file ?
    Another question, the send speed is also influenced by the computing power of the server?
    Because now i’ve a 2 core e 2GB of ram.

    Thanks ika.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.