Home Forums Newsletter Developers Getting 403 code but correct data on /subscribers/{id}

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #261746
    Bruno Faúndez
    Participant

    First of all, thanks for this cool plugin. It has been very useful for me.

    I’m integrating the newsletter from my blog, which is hosted on a cpanel server, to the backend of my web app written in node.js via the REST API V2.
    To test the API, first I’m making requests using Postman and decided to try the /subscribers/{id} endpoint using my own email as id, since I know that I’m already subscribed to some lists. The weird thing is that the requests returned me the correct data (my user fields and the lists I’m subscribed to) but it gave a 403 code.

    At first I thought that it was related to a problem with my hosting, but I tried other endpoints (using Basic auth with client and secret keys, as indicated in the tutorial) and they gave me 200 OK code after the request.

    Did I make something wrong? Is there a problem with that particular endpoint?

    A summary of my requests:

    GET /subscribers/{id} 403
    GET /subscribers 200
    GET /lists 200
    GET /newsletters 200

    #261810
    Gioacchino
    Keymaster

    Hello,

    we are so glad you like the plugin.
    We just tested the v2 api in several environments and the response to newsletter/v2/subscribers/{email} is fine.
    Could you send us raw request and raw response from Postman app hiding sensible data like ‘Authorization’ and ‘Cookie’ header.
    Thanks

    Gioacchino

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.