Home Forums Newsletter Plugin Support Cannot subscribe- going to 404 but checked all persmissions

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #12286


    I am working for a client who has this plug-in installed on their site. After the recent update in November no one can subscribe, it’s going to a 404 error. Before that the plug-in worked fine for over a year. I have checked with the host and they cannot find a issue, I have deactivated all other plug-ins and retry without success. Can you please help?


    The subscribe form is in the footer…



    Check on subscription steps panel if the link of the Newsletter dedicated page is correct.

    Bye, Stefano.
    Already tried Nearby Photos? Try it and see what’s happening around you!


    Yes, it is correct… http://www.fallingsprings.net/newsletter-3

    It is happening with or without the link in place.


    Hi I checked your blog, the 404 page is de to some server configuration. Check for an .htaccess file inside the wp-content or plugins folder. Probably there is a block or those folder are not readable by the apache.

    This is the only reason for that error. You can even ask the provider while the url produced by the subscription submission gives a 404: they should be able to sort out the problem.


    I think this was caused by the recent update. Everything was working properly before the auto update occurred, from what I can tell.


    The update can produce two possible problems: 1. the file wp-content/plugins/newsletter/do/subscribe.php is missing, or the new file copied by wordpress from the new version has wrong file system permissions. A 404 cannot due to the plugin it self, it is a structural problem.

    Check if that file exists. If not, delete the plugin and reinstall (nothing will be lost).


    I contacted the host first, they cannot find a reason why the file won’t run.

    I also already checked the subscribe.php file, it’s perfect.


    A 404 response to this file


    should be solved by your provider. Have you some security plugin installed?


    No security plug-ins, I even tried disabling all plug-ins and testing, the same issue.


    Hi, your server is configured to show a file list


    but if you try to load a file, it gives 404. So it’s clearly a server problem. Try to put a txt file in the folder and see if it will be loaded. Then rename it .php a cdo the test again.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.