Home Forums Newsletter Plugin Support [RESOLVED] 403 Forbidden error when trying to save a custom hardcoded form

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #25570
    qzelle
    Participant

    I tried to add this code to the Form Customization Form 1 field (http://emergencyadapters.io/wp-admin/admin.php?page=newsletter_subscription_forms), but I get a “403 Forbidden.
    A potentially unsafe operation has been detected in your request to this site.”

    <script type=”text/javascript”>
    //<![CDATA[
    if (typeof newsletter_check !== “function”) {
    window.newsletter_check = function (f) {
    var re = /^([a-zA-Z0-9_\.\-\+])+\@(([a-zA-Z0-9\-]{1,})+\.)+([a-zA-Z0-9]{2,})+$/;
    if (!re.test(f.elements[“ne”].value)) {
    alert(“The email is not correct”);
    return false;
    }
    for (var i=1; i<20; i++) {
    if (f.elements[“np” + i] && f.elements[“np” + i].required && f.elements[“np” + i].value == “”) {
    alert(“”);
    return false;
    }
    }
    if (f.elements[“ny”] && !f.elements[“ny”].checked) {
    alert(“You must accept the privacy statement”);
    return false;
    }
    return true;
    }
    }
    //]]>
    </script>

    <div class=”newsletter newsletter-subscription”>
    <form method=”post” action=”http://emergencyadapters.io/?na=s&#8221; onsubmit=”return newsletter_check(this)” _lpchecked=”1″>

    <input type=”hidden” name=”nr” value=”page”>
    <table cellspacing=”0″ cellpadding=”3″ border=”0″>

    <!– email –>
    <tbody>
    <tr>
    <th>Email</th>
    <td align=”left”>
    <input class=”newsletter-email” type=”email” name=”ne” size=”30″ required=””>
    </td>
    </tr>

    <tr>
    <td colspan=”2″ class=”newsletter-td-submit”>
    <input class=”newsletter-submit” type=”submit” value=”Subscribe”>
    </td>
    </tr>

    </tbody>
    </table>
    </form>
    </div>

    I thought it might be due to the Wordfence plugin, so I disabled it. I still got the error, so I checked my .htaccess file. Here’s what’s in it:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Not sure what’s going on here…

    • This topic was modified 6 years, 2 months ago by qzelle.
    • This topic was modified 6 years, 2 months ago by qzelle.
    #25572
    qzelle
    Participant

    Resolved!

    I re-enabled Wordfence, then changed Firewall to “Learning Mode” and it let me through. Yay.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.